Page 80 of 80 FirstFirst ... 3070787980
Results 791 to 799 of 799

Thread: Stuck In Hawaii D9G Still Wont start!!! Bad Injection Pump????

  1. #791
    Join Date
    Nov 2006
    Location
    Corralitos, Ca.
    Posts
    15,105

    Default

    What rubber boots? I'm not seeing any rubber boots called out in the parts diagrams.

  2. #792
    Join Date
    Nov 2007
    Location
    NW Ohio
    Posts
    3,911

    Default

    If it's the steering clutch control then there are lip type seals on the shafts but no boots like on the front of the old clutch booster controls.

  3. #793
    Join Date
    Feb 2018
    Posts
    351

    Default

    Quote Originally Posted by Rome K/G View Post
    If it's the steering clutch control then there are lip type seals on the shafts but no boots like on the front of the old clutch booster controls.


    Rome you are correct they must be lip seals on the steering clutches....

  4. #794
    Join Date
    Feb 2018
    Posts
    351

    Default

    Quote Originally Posted by Rome K/G View Post
    Good to hear from you! Those orings around the top of the chambers can go bad and look like oil but it is coolant, drain the coolant down and remove the chamber and clean the ring surface area on the head good, clean the prechamber if reusable, anti-seize the threads and oil the oring and around the head area, install bottom washer, torque chamber to 200 ft lbs. I dont know if you have the special tool to remove the chambers? Its the splined bolt type.
    Good to here from you too! I do believe that it is oil as it is black and not coolant... I took a picture and need to really take off the hood to get in their properly.... I know it its not the head gasket just the oil is dripping from above and runs the length of the head and it appeared to be the head at first but it super wet on top... That is why I believe it is the pre-cup or pre-chamber....Any suggestions would help with what you guys might be thinking... I know the pre-cups have o rings and I was thinking only coolant as the cups are surrounded by coolant... Let me know your thoughts...

  5. #795
    Join Date
    Nov 2007
    Location
    NW Ohio
    Posts
    3,911

    Default

    Unless the rocker box gasket has a bad leak right by the prechamber. I would steam clean it then run it some more and recheck it.

  6. #796
    Join Date
    Feb 2018
    Posts
    351

    Default

    Quote Originally Posted by Rome K/G View Post
    Unless the rocker box gasket has a bad leak right by the prechamber. I would steam clean it then run it some more and recheck it.
    Ok will do and get back to you....

  7. #797
    Join Date
    Jul 2016
    Location
    Lancaster CA
    Posts
    671

    Default

    Leaking on top of the head around #3, I would bet a rocker box gasket, decompression shaft seal (between the 2 boxes) or even a crack in a rocker box near the seal area.
    Cat 12 grader, 8T6995 running and restoring, Cat 12 grader 9K3585. parts machine, Adams leaning wheel Pull grader Mod # 22, ser#438

  8. #798
    Join Date
    Feb 2018
    Posts
    351

    Default

    Quote Originally Posted by oldbeek View Post
    Leaking on top of the head around #3, I would bet a rocker box gasket, decompression shaft seal (between the 2 boxes) or even a crack in a rocker box near the seal area.

    I will bet you are correct... It seems it cannot be the pre-chamber as from what I have read is only the coolant...

  9. #799
    Join Date
    Feb 2018
    Posts
    351

    Default

    Quote Originally Posted by Rome K/G View Post
    If it's the steering clutch control then there are lip type seals on the shafts but no boots like on the front of the old clutch booster controls.
    Any idea on Part number for the lip type seals on the steering clutch control???


    The oil leak was the rocker boxes gasket for 123. I ordered all the parts for the old girl and am planning on doing both not just the ones leaking.... I am going to need to fix the steering clutch control leak as she is leaking pretty good through those seals...


    Lastly, The ripper all 4 actuator seals need to be repacked... Then she should be good for a minute until a hose bursts.... LOL.... Oh the joys of owning an old girl that needs attention... She is strong though and my god can you do a ton of work in a short amount of time....


    Stay safe.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •